Announcement

Collapse
No announcement yet.

SpeedTree Importing to Houdini - SpeedTree ERROR: Material creation failed

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • SpeedTree Importing to Houdini - SpeedTree ERROR: Material creation failed

    I've been trying to import in speedtree file into Houdini. I export out mesh as Alembic and import in a stmat file. As soon as I do that, I get a prompt "SpeedTree ERROR: Material creation failed." However the model imports in, but when I go inside the node, there is a materials node. Materials node has nothing inside. I really need someone to help me out with this. Thank you.

  • #2
    Hello,

    Depending on the type of material you are making, there may have been changes. Renderman, for instance, has changed a lot since our last release.

    We have updated the importer internally since then, however. I am including it here. Hopefully it fixes the problems you are seeing, but if not, I imagine we'll run into them too during testing before the next release.

    If you still have trouble, you could uncomment the error prints in the OTL script and find out exactly where the material is going wrong, if you are so inclined. The script just uses regular import methods for the mesh, and then fixes up the materials. So you can always import the mesh directly if you don't mind doing the materials by hand until we put out a fix, too.
    Attached Files

    Comment


    • #3
      Thank you, Greg. To be more specific, I am having a problem with converting to Redshift materials. After reading your comment, I tested the new file you attached here. I tested both Mantra and Redshift. Mantra works, but Redshift is still having a problem. I wonder if the newest version of Redshift is causing the problem. Was there any Redshift material failure case reported by other Redshift users? If it's a new Redshift version that's causing the problem, I'd move on and wait until the new version of importer comes out. But if it's my machine or the way it was installed I'd like to find out what's causing it and fix it.

      Anyway, thanks again for your help and the file. I really appreciate it.

      Comment


      • #4
        By the way, do you suggest uninstalling the program and install again? If so, do I need to email again for another license?

        Comment


        • #5
          Hello,

          Uninstall the previous OTL before using this one, of course. But I don't believe reinstalling any apps should help. If you do, though, the license should still be saved.

          I'll have to log to look into redshift, possibly upgrading to newer versions, as I am unsure what could be going wrong.

          The OTL I just gave you actually should print out more information than before about where the error occurs. If you are handy with python in Houdini, you could crack open the OTL script and find where it says. It's most likely a property name has changed in SpeedTreeMaterialCreatorRedshift.CreateMaterial() function. But if not, we'll look into it.

          Comment


          • #6
            Got it!

            Uninstalled the previous one and installed the new one. Houdini Console still only prints out Material creation failed.(See attached). I can investigate a little more. Thank you.
            Attached Files

            Comment


            • #7
              So to give you more background, I have 2 PCs: one I've been using and another one I just bought. Previous PC had Houdini and SpeedTree both installed. Importer worked on Mantra and Redshift. When I got my new PC, I uninstalled SpeedTree and transferred licenses to the new one. The importer and the installer for SpeedTree I was using are exactly the same version. However I installed newer versions of Houdini and Redshift on the new setup. When I tested it on the new machine, Redshift didn't import. I honestly don't believe they changed much for Redshift in this version either. I already uninstalled the SpeedTree and re-installed, and it didn't fix. I could potentially roll back the versions of Houdini and Redshift to match my old setup. I have a feeling that it won't do much either, but I have no other options. Am I supposed to get more detail on Houdini Console where it went wrong? That usually happens. It happened when I was troubleshooting Megascans Livelink. (That plug-in didn't work either so I had to customize the python script on their UI.)

              Thanks again Greg for reading.

              Comment

              Working...
              X