Announcement

Collapse
No announcement yet.

Black Billboards SpeedTree for Unity

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Black Billboards SpeedTree for Unity

    I'm getting completely black billboards exported from SpeedTree Modeler for Unity (7.1.5 Mac) for all my trees. Do I need to do something special to light the billboards in SpeedTree? I can't find billboard settings anywhere in SpeedTree. For example this tree is generating these billboards:

    Click image for larger version  Name:	Screen Shot 2018-01-05 at 10.04.30 PM.png Views:	1 Size:	417.2 KB ID:	3610Click image for larger version  Name:	MexicanThreadGrass_Atlas_Billboards.png Views:	1 Size:	107.2 KB ID:	3611Click image for larger version  Name:	Screen Shot 2018-01-05 at 10.11.08 PM.png Views:	1 Size:	149.4 KB ID:	3612

    Edit:

    I've opened the Broadleaf sample tree in modeler and saved it out again and the billboards went black, so I think this may be a bug in the modeler. The sample billboards look like this, but after saving them from modeler they look like this:
    Click image for larger version  Name:	Broadleaf_Desktop_Atlas_Billboards-orig.png Views:	1 Size:	252.0 KB ID:	3613
    Click image for larger version  Name:	Broadleaf_Mobile_Atlas_Billboards.png Views:	1 Size:	8.4 KB ID:	3614
    Last edited by Samuel223; 01-05-2018, 05:52 AM.

  • #2
    Hello,

    What kinda of Mac are you using? And what kind of graphics card/chip (if it's not standard)?

    You do have a few billboard options on the tree generator in the Modeler. Can you try dropping the billboard atlas size down to see if that alleviates it? It might be for some reason it can't render into an offscreen buffer that big.

    Comment


    • #3
      Hi Greg,
      Thanks for responding. It's a MacBook Pro with Iris Pro graphics.

      I've tried turning down billboard atlas size to the lowest setting 128x128, but they're still black.

      Comment


      • #4
        Hello,

        The Compiler shaders don't seem to be working correctly on your computer / graphics card. If the shaders failed completely, the Compiler would fall back to other methods of rendering. But they're loading, just not working correctly. I'll have to log to look into it.

        I'm really sorry I don't have a quick answer for you. If you contact [email protected], we can process a refund since you're not able to use it currently.

        Comment


        • #5
          Thanks for your help anyway. I've just moved to a Windows platform yesterday and the billboards are working fine now so no need for a refund. I expect other MacBook users will probably experience this issue, so it would be good to get it fixed at some point

          Comment

          Working...
          X