Announcement

Collapse
No announcement yet.

Trouble getting the hang of subsurface in SP8 for UE4

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Trouble getting the hang of subsurface in SP8 for UE4

    It's me again!

    So far we've been enjoying the new version immensely. The new options and the optimized workflow are a treat!

    However, I've been having some issues with some of the available maps for the materials, namely the subsurface/subsurface% ones, especially when making leaf clusters for my tree.

    They do work in Speedtree, even if I ramp up the intensity of the light.
    Screenshot inside speedtree. Works great!
    Subsurface maps

    But when imported to Unreal, making sure to select the "include subsurface" option, the subsurface doesn't work:

    Unreal preview. All color from the leaves has faded to white.

    When I check the material, there is no subsurface map, and the material shading model is set to default lit.

    Do I have to manually change the shading model and import the subsurface map? Or am I doing something wrong from the speedtree step?

    Thanks in advance.

  • Greg Croft
    replied
    Hello,

    Two-sided doesn't change the wind motion, but it sounds like the two sides of your mesh are intersecting during wind. When you want to use a two-sided material, you should not have a two-sided mesh. So make your mesh again without doing two sided, and there should be no more intersection in wind.

    Leave a comment:


  • morningstar666
    replied
    Thanks for the tip. Enabling the two-sided option in the leaf material does help out a lot!

    Now I have another question-- do you also have to enable the two-sided option in the material you use in the tree itself? Or do you only have to do it when setting up the leaves in the cluster? Because if I make the cluster material two-sided, the wind animation for my texture breaks entirely. As in, rather than moving in a swooping motion, the cluster texture constantly switches back and forth between its two sides and it's rather jarring. :/

    Leave a comment:


  • Greg Croft
    replied
    Ah, you made the mesh itself two-sided. You need to make the materials two-sided instead, in the material asset bar.

    The subsurface texture exported to UE4 is a combination of color and amount. The final effect depends on the light color, and how bright it is, etc.

    Leave a comment:


  • morningstar666
    replied
    In speedtree, when making the mesh cutout for my leaf cluster material I checked the two-sided option-- do I have to do something else to make the material two-sided or is that it?

    And I checked the leaf-mat material that was automatically generated when importing the .st file-- everything else was the billboards and trunk materials.

    What I'm confused about is the color of the subsurface itself-- it's green (the way I set it up in Speedtree), while in unreal is very desaturated, almost white. Is this normal?

    Leave a comment:


  • Greg Croft
    replied
    Hello,

    Subsurface is only added to the two-sided materials. Are you sure you're checking the leaf material? It certainly looks like you have subsurface on the leaves in your pic...

    Leave a comment:

Working...
X