Announcement

Collapse
No announcement yet.

Speedtree 8 Unity not exporting LODs

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Speedtree 8 Unity not exporting LODs

    Hi, I am using the Speedtree 8 editor for Unity for the first time. Exporting the sample trees works fine, but when I try to export my Speedtree 7 trees from Speedtree 8 the LODs will not export. I followed the instrutional video and checked the dynamic LOD box and gave it three LOD's, but it will not export them, I mean it will export the tree but give it only one LOD.

    I also get this error message:

    "This model contains legacy generators that do not suppport LOD generation. Please consider upgrading these generators.
    > Autosaving '~BaldCypress_Hero.sbk' ... success."

    I tried to find a button to upgrade the generator on the tree but didn't find one and am not sure how to do this.

  • #2
    Hi,

    The older v7 trees need Wind and LOD to be retuned. To upgrade your model, in the Generation editor, select all your generators and then click the 'Upgrade' button in the Generation editors toolbar. So once you update your model's generators to v8 generators, you then need to go to the 'Global Properties' -> 'Level of Detail' group and 'Enable' LOD. Then change the 'Number' property from 1 to 3, this sets the number of levels you have on your model.

    It probably didn't work because the generators weren't upgraded.

    Hope this helps!

    Comment


    • #3
      Hi Sonia,
      Thanks for getting back to me. That sort of worked. It will upgrade and do LOD's, but unfortunately it also messes up the tree, all the nodes get scrambled and the tree looks nothing like it did before, just a scrambled mess. I guess I will have to try to remodel them or have to use the textures and make them from scratch again if I want to use them.

      Comment


      • #4
        I can confirm MarkR 's findings. After clicking upgrade on nodes for different trees they are left either naked or white cards in place of the fronds (depending on the tree). With the free exporter the global properties button is grayed out now allowing us to configure LODs; does this mean that we cannot upgrade our old trees without a subscription?

        Comment


        • #5
          Hi,

          Because of the changes we made with Materials and assigning meshes to materials, when you upgrade an v7 tree in the v8 modeler, you will need re-assign the mesh to the correct material and then assign that material to the correct generator. The cards appear when nothing is assigned to that generator.

          As for the grayed out properties in the subscription modelers, when you don't subscribe then you can only export models. If you want to make changes then you would have to subscribe.

          Hope this helps!

          Comment


          • #6
            Originally posted by SoniaPiasecki View Post
            Hi,

            Because of the changes we made with Materials and assigning meshes to materials, when you upgrade an v7 tree in the v8 modeler, you will need re-assign the mesh to the correct material and then assign that material to the correct generator. The cards appear when nothing is assigned to that generator.

            As for the grayed out properties in the subscription modelers, when you don't subscribe then you can only export models. If you want to make changes then you would have to subscribe.

            Hope this helps!
            So in order to export our trees from ST7 --> ST8 with LODs we have upgrade the nodes and in upgrading the nodes we lose meshes and materials. To reassign meshes and materials however, we need a subscription; is this correct?

            Comment


            • #7
              Hello,

              The free export mode of the v8 modeler is to export trees already prepared for v8. This lets you export a tree that you buy to any engine, with different export settings, seasonal variations, etc.

              Any editing of the tree, including upgrading an older tree to v8, would require an active subscription. Even though the v8 Modeler can load v7 trees, they usually require some tweaking to fully upgrade them. For instance, we take a shot at upgrading old materials, but you would want to take advantage of all the new PBR maps available in v8 for the best result.

              Hope this helps

              Comment


              • #8
                Originally posted by Greg Croft View Post
                Hello,

                The free export mode of the v8 modeler is to export trees already prepared for v8. This lets you export a tree that you buy to any engine, with different export settings, seasonal variations, etc.

                Any editing of the tree, including upgrading an older tree to v8, would require an active subscription. Even though the v8 Modeler can load v7 trees, they usually require some tweaking to fully upgrade them. For instance, we take a shot at upgrading old materials, but you would want to take advantage of all the new PBR maps available in v8 for the best result.

                Hope this helps
                Thank you for the clarification.

                Comment


                • #9
                  Hi

                  Jumping in here as I have the same problem after upgrading this week. I can confirm the same issue and I have an active subscription.


                  I have a v8.4.2 (Unity Subscription Edition)

                  It appears, I can't have LODs unless I upgrade generators and upgrading them has, so far, destroyed my mesh to the point where 'tweaking' won't save it - I might as well scrap it and remake it from scratch. I made hundreds of trees in v7 and this issue will create a ton of work. ( I have lots of trees with hand drawing which are replicating their real world counterparts and a random generation won't do)

                  I can open v7 Trees fine, can resign to PBR textures fine, but upgrading the generators changes my mesh too much. Are there any techniques or tips to minimize branches from doing such extreme randomized distortions when upgrading generators, either in Speed tree 8 or by re saving in Speed tree 7 ? Or can I export LODs made in 7 and import for use in 8?

                  Any work around other than upgrading the generators (when it brakes the mesh) or start again would be appreciated.


                  Oh, one other thing. Above Sonia stated " ...To upgrade your model, in the Generation editor, select all your generators and then click the 'Upgrade' button in the Generation editors toolbar..." I can only work on them one at a time. ( I can group select them all, but then when I right-click, only one is selected) Is that what is meant or should I be able to upgrade generators a group selection?

                  Thanks for your help!
                  Last edited by jezelf; 07-30-2020, 03:57 PM.

                  Comment


                  • #10
                    Hello,

                    The new way we do LOD only works with the newer generators, unfortunately. So if you move to v8 for the PBR materials and other new stuff, you'll need to upgrade them.


                    > I can only work on them one at a time

                    If you hold control and right click, the selection will stay. There is also an option to do it under the Action button menu. However, it's probably better to do one generator at a time, starting from the trunk and moving upwards. A whole tree upgraded can look a mess, while each individual part isn't too bad by itself.



                    If you made your main tree parts with hand drawing, I imagine that will upgrade pretty well even though procedural things might move. The movement shouldn't be extreme, as it is really is a lot of the same properties but with different random seeds. But if you used a lot of node editing, those will be lost.

                    If you have a particularly troublesome tree, feel free to email it to [email protected] and we can take a look and offer suggestions.

                    Comment


                    • #11
                      Thanks for the speedy response!

                      Hmm, yeah I did a lot of node editing - on a lot of trees, to get them the way I wanted - that's probably it, then. So far, every tree looks like it's going to be troublesome. Thanks for the support email I may contact you guys soon. I'll go through a bunch more first and see if things improve before I do though.

                      Cheers

                      Comment

                      Working...
                      X