Announcement

Collapse
No announcement yet.

SpeedTree v8 for Unity export material color is wrong

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • SpeedTree v8 for Unity export material color is wrong

    When you load a tree in the modeler, it's green. When you export a tree to Unity, then the material color of the tree is orange. Is there a way to set the hue color to white instead of orange or alpha to 0?
    Last edited by Rowlan; 01-26-2019, 04:48 AM.

  • #2
    @Rowlan Which version of unity did you use with Speedtree 8? I tried 2018.3 and 2019.1 and got this error "SpeedTree file does not contain run-time data. Be sure to re-save it using the Unity-specific version of the SpeedTree Modeler"

    I'm pretty sure the tree I got was a Speedtree Game 8 UE/Unity compatible

    Comment


    • #3
      SpeedDude you have to download and install the modeler, load the speedtree 8 file into it and with the modeler export it to unity. You can't just use the files from the store.

      Comment


      • #4
        Hi,

        In your export settings, check to make sure that the 'Variations' checkbox isn't selected. This would had variation colors to the model.

        Let me know if this helps!

        Comment


        • #5
          Thanks, but didn't work. The hue is still orange. Here are the Unity settings after the import:

          Click image for larger version  Name:	hue.png Views:	0 Size:	10.3 KB ID:	6050

          My trees all have an orange touch that way. I'd like that to be gone. Any suggestion other than to manually change the alpha of the hue color every time? Thank you very much in advance

          Comment


          • #6
            Hi,

            There is a 'Enable Hue Variation' checkbox under that section in the screenshot you posted, just disable that.

            Hope this helps!

            Comment


            • #7
              Found it, thank you! Is there a setting where I can disable this feature altogether? I don't want orange trees. I want them the way they come from the modeler. By the way, other users have the same problem. It's just redundant work, especially when you first have to find out what causes this

              Comment


              • #8
                Bug-Update: that only modifies the LOD0 variation, the other LODs still have Hue Variation active when I deselect it in the SpeedTree

                Comment


                • #9
                  Thank you, we will look into it.

                  Comment


                  • #10
                    I am having a similar issue with .spm trees saved from speedtree 7 in unity 2019.1.5 ... with hue variation checked off, the hue is still adjusted on LOD models for the object.. is there any known solution or workaround to this?

                    is there a way i can control the actual shift in hue to a more neutral color?
                    Last edited by rick.falck; 07-10-2019, 02:10 PM.

                    Comment


                    • #11
                      Hi Rick, just to confirm- Are you updating the version 7 tree and saving the file in version 8 and then exporting into Unity 2019.1.5 or are you having issues with the v7 tree as is in 2019.1.5
                      We will report the bug to the Developers at Unity. In v8, you can select the hue color from the "variations" option found in the "materials" bar.

                      Comment


                      • #12
                        I'm using v7 trees in 2019.1.5

                        Comment

                        Working...
                        X