Announcement

Collapse
No announcement yet.

Possible Bug : Wind exported to 3Ds Max doesn't work

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Possible Bug : Wind exported to 3Ds Max doesn't work

    Hi,
    So this is what happens. I export one of my trees to Max, with the wind animation included, however upon import in Max there's no wind. The same is also true for the sample trees that ship with SpeedTree. I have to mention that, they do however work perfectly in Maya. I have the animation and everything checked on, but there's no movement.
    I'm using Max 2014, and 2016. The SpeedTree version is 7.1.1 Studio Edition (windows).
    I'm not sure if I'm doing something wrong. But, it's weird that it works in Maya and not Max, with the same settings.
    Thanks,
    Ashkan

  • #2
    Hi,
    I will list the steps to exporting and importing a SpeedTree Mesh with the wind setting to see if it will help you with you issue.

    1. Go to File -> Export Mesh -> Exporter Window should pop up
    2. Save it as a Autodesk FBX file and unde Extra Data on the right hand side include the wind.
    3. Go into 3D Max - Import the SpeedTree 3D Object
    4. A pop up window should appear. Make sure the Animation check box is checked and underneath Extras, make sure Point Cache is checked along with baked animation.

    I hope this works for you!
    Julia

    Comment


    • #3
      Hi Julia,
      Thank you for your reply, however that was not the issue.
      Actually I found a way around it. The problem appears to be the cap geometry from the first level up, which upon import will cause the model to have extra vertices, leading to a mismatch between the exported point cache and the current increased amount of vertices of the model.
      I also believe it has something to do with FBX importer of Max, since this is not an issue in Maya. However, I am not sure why this doesn't happen to other nodes. I have to mention that the scale of the tree or tuning LOD settings did not help; I thought that SpeedTree gets rid of the small polygons on export, but then, why does it increase vertex count? I have no idea where those extra vertices may come from.
      Also, it happens to almost all of the trees that I make, so it is not a specific one. I tried to get rid of the isolated vertices in Max, but it still doesn't make it match to the exported point cache.
      So, at this point the exported animation on "cap" geometry doesn't fully work in Max. Hopefully it'll get fixed soon.
      Thank you,
      Ashkan

      Comment

      Working...
      X