Announcement

Collapse
No announcement yet.

Store purchased unity trees - No Run-time data

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Store purchased unity trees - No Run-time data

    When I import most of the trees I purchased from the store here on Speedtree, I receive a rather generic error message saying "SpeedTree File does not contain run-time data. Be sure to re-save it using the Unity-specific version of the SpeedTree Modeler".

    Does this mean I need to go through each and every tree (BTW, I probably own most, if not all of the trees now) and resave them? Where is that documented, I searched around and the documentation only says basically that I just need to unzip the download in the asset directory and fix the NormalMap Settings.

    I am not really complaining, I just want to be sure what I need to do. Also, that error message would be a LOT more helpful if you indicated while file has the issue, in the version I bought, there are several SPM files per zip file.

    Thanks,
    John

  • #2
    Hey John,

    Just wanted to let you know I'm looking into the issue. I have yet to replicate the issue. Just to verify, this is happening with Unity trees that you've purchased from our store, and not trees from another version of the Modeler? If it's happening with Unity SpeedTrees, can you tell me which ones specifically are giving the error?

    I'll reply here when I find something more definitive.

    Regards
    Last edited by Dave Ohlman; 03-11-2016, 05:23 PM.

    Comment


    • #3
      Correct, these are all of the unity tree packages I purchased.

      Comment


      • #4
        I am going back zip file by Zip File; it looks like at least one of the trees I purchased points to the wrong version. I purchased the Unity version of White Oak, but when I try to import it, I get all of the errors like what I mentioned in my first post, so I tried to open the tree in the Speed Tree Modeler, and it tells me that I cant because it is the UE version of the tree.

        How do I get the correct version of the tree, and also, how do I know when/if there are updates to any of the trees I have purchased?

        Comment


        • #5
          Hey John,

          Which version of Unity are you using?

          If you log in to your account on the store, you can redownload the White Oak. That was an issue that was resolved some time ago. At this point we don't have a system to notify when updates are made to trees on our store.

          Regards

          Comment


          • #6
            5.3.3f1

            Thanks, I'll go grab the updated tree.

            So, really, there is no way to tell whether or not I have the most recent version of the trees, is that on the radar? Even if it were as simple as adding a data to the list of the trees in the store (last updated), that would be enough for now.

            Comment


            • #7
              Okay, me too. Have you tried to redownload any of the Unity trees and retest them in the Unity Engine. I have loaded several of the trees that you purchased from the store and none of them is giving me a "no run time data" error. I have seen this error before, but only when attempting to open trees not modeled with the Unity specific version of SpeedTree. Again, none of the trees I have tested from the Unity side of the store are giving me that error.

              Comment


              • #8
                Yes, getting the updated tree corrected the issue I encountered :-). Thanks.

                Still wish there was a way to know when the trees were updated though...

                Comment

                Working...
                X