No announcement yet.

Unity Loading Asset Loop Error

  • Filter
  • Time
  • Show
Clear All
new posts

  • Unity Loading Asset Loop Error


    I'm having some major issues. After creating quite a few tree's I went to export them to my game, using Unity 2019.1.10. While exporting from speed tree seems fine, inside of the engine though is not. It creates a ghost folder (with no name) as well as getting stuck in an importing asset loop. The only way out of this loop is to delete the files, as after every click it repeatedly "loads assets". From what I can tell the export function from speed Tree shows that it's exporting just fine. With no alarming errors popping up for anything. I also tried poking around multiple settings thinking that might be the case. Turning on exporting external materials seems to help with a few of our tree's but the majority still give us that error. I did, however, notice when only exporting bilboarded tree's it worked just fine. However, bill-boarded tree's don't cut the wood in this case : ). So I'm pretty sure it's something with the LOD's but it beat's me what could be causing it.... I can give tree files upon request.

    Ghost Folder (below SpFrst)
    Click image for larger version

Name:	Capture spdTree.PNG
Views:	350
Size:	1.9 KB
ID:	7464

  • #2
    Hi Cortes Productions : since you've tested different export settings and it's an internal folder issue, this appears to be something we should bring to Unity's attention.

    Thank you for letting us know, we're sorry about the issue!


    • #3
      Sorry for the late reply,

      I mean as far as the folder issue isn't necessarily the problem just something I noticed that probably shouldn't happen.

      The main issue is the looping "assets imported" every time I click after applying one of the exported speed tree's to my project. It's as if the file is always continuously being updated upon being in the project. No other object has so far done this...and only a few of the speed tree's I have custom made are doing this. I'll bring it up to Unity's attention, but it seems like this would be more of something to do with Speed Tree's side of things with how LOD's are being handled, especially since this issue goes away when only exporting billboarded versions of the tree's that are giving me issues..


      • #4
        Sorry for the double post.

        After writing this I realized I could potentially turn off the dynamic LOD's. I'm very sure this issue is with the dynamic LOD settings inside of Speed Tree. Disabling it on the base tree node stops the "assets imported" loop.


        • #5
          Sorry for triple posting.

          You were right, it's Unity's side. Going through a bit of troubleshooting, updating the engine fixed the issue. Sorry for all the trouble, thanks for getting back to me earlier! : D tree's are in and looking great!


          • #6
            I am having the same problem with Speedtrees and am using the same version of Unity. Will update my Unity version and see if that helps. Thanks for reporting this so I could find a possible solution.