Announcement

Collapse
No announcement yet.

Bug: Hand drawn trunk corrupts and deviates from its underlying spine.

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Bug: Hand drawn trunk corrupts and deviates from its underlying spine.

    I'm trying to use hand drawing to start a tree from scratch. Starting with the trunk I created a handdrawn trunk generator from the generation menu and drew out a short trunk off to the side. I don't want to use this first trunk because the default settings create an undesirably fat trunk, whereas I need something a little smaller and more delicate. So I select the generator and modify its settings to my liking. Making it thinner, turning off LOD, adding more spline segments, nulling out the value randomisers, etc. After that I press down on the spacebar and start drawing out a second trunk. This one I want to be the one I end up working with (planning to delete the original one later). But now I'm getting a very strange anomaly. After hand drawing a certain distance, the spine corrupts and assumes a different shape all together at its base. Going into node-editing mode reveals the underlying spine itself to still be correct. The resulting trunk however is wholly wrong. Check out the image. On the left is the original fat trunk I plan on deleting later. On the right is the abberation.

    Click image for larger version

Name:	Screen Shot 2016-11-08 at 13.26.09.jpg
Views:	1
Size:	61.6 KB
ID:	3397

    I've attached the .spm file containing the hand drawn generator. To reproduce:
    ÔÇóOpen the file and make sure you are in the perspective viewport
    ÔÇóHold down the spacebar and draw out a trunk. To make the fault more obvious, draw out something S-shaped or otherwise curvy rather than a straight trunk.
    After a certain distance the trunk snaps out of position at the base.
    ÔÇóPress TAB to enter node editing mode and select the wonky branch. Notice that the spine still holds the shape you drew, but the resultant branch has deviated from it.

    handdrawingBug.spm.zip

  • #2
    Hey there,

    It's your Welding: Distance setting. Either disable welding or lower the distance value to something like 1.0 or thereabouts.

    Regards

    Comment


    • #3
      Sweet! You're right. That's it. Perfect now. Thank you Dave, glad to hear it's not a bug.

      Comment

      Working...
      X