Announcement

Collapse
No announcement yet.

Issues with custom trunk and export to Unreal. Using Speedtree v8.4.2 for UE4

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Issues with custom trunk and export to Unreal. Using Speedtree v8.4.2 for UE4

    Hi, can somebody help me out with the pipeline for using custom trunks and unreal 4

    I'm trying to combine megascans with speedtree. I'm happy with the current (WIP) result but i'm running into issues getting in unreal 4.


    Currently i'm using zone generators for the custom trunk ( split in 2 generators since I've 2 materials)
    - Wind works great. With the zone's slightly bending in the wind like a real trunk
    - Billboards look good when exported
    - The custom mesh lod's don't appear to work using the speedtree lod slider
    - When exporting to unreal, lod 0 works fine, but in the next lod's have the custom trunk disappear when exported to unreal
    I get the following error in the log: [ERROR] this model contains legacy generators that do not support LOD generation. Please consider upgrading these generators. I'm not using any lagacy generators, but I assume this is caused by the 'Zone ' generator


    A few other things I tried:

    Using Mesh forces for the custom trunk and enabling 'include in model' :
    - lods work, but wind doesn't. There doesn't seem to be an option to add wind for Mesh forces

    Using leaf mesh generator for the custom trunk:
    - I can position them exactly as I want
    - When testing the Lod's the trunk started to scale and move (just like a leaf lod works). I couldn't figure out how to turn this off without disabling it for the actual leaves also
    - Wind doesn't look good since it's meant for leaves

    Using fronds generator for the custom trunk:
    - This needs a Branch generator inbetween and I can't get the scale, orientation and position right. I want it to be exactly the same as how I exported it from the 3d software
    - Haven't tested it, but I'm concerned the wind won't behave right either

    I checked this forum and I've tried out everything I could think of, but I feel I can't figure out a solution. Help would be much appreciated!
    I added my current graph and results below. I can also upload the speedtree file if that helps

  • #2
    Hi Roel,
    A couple of things are going on in your first attempt.
    1. Zones do indeed not allow for dynamic LOD
    2. The custom trunk is disappearing because all three slots for LODS must have a mesh loaded in.
    3. With mesh forces that is correct, the mesh does not have a spine so you wouldn't be able to get movement there.
    4. As a leaf mesh, that is correct and you'd have to max out the scaling for leaves.
    5. fronds is probably the most effective method here because the spine can now move in the wind and the scaling is matched to the spine.
    While using the subscription modeler, your workflows are all valid attempts but each come with some "side affects". There is however a much easier way available in the non-hobby flavor or our software!
    The workflow for this type of setup available in SpeedTree Games with an Indie or Full licence.
    1. It allows a LODing mesh to join with SpeedTree geometry and can blow in the wind.
    2. You would not have to hand-draw to place your trunks and you can weld your geometry seamlessly.
    3. You'd need to put your asset in the scene on the "mesh" generator.
    4. We have a breakdown on how to do this found here:
      timelapse: https://youtu.be/vaCp8cCmms4
      tutorial: https://youtu.be/_EFGLOT6mIM
    5. Here is the documentation if needed as well: http://docs8.speedtree.com/modeler/doku.php?id=pg_intro

      I hope this helps but let me know if you get stuck

    Comment


    • #3
      Hi Sarah,

      Thanks for your help

      About this one "2. The custom trunk is disappearing because all three slots for LODS must have a mesh loaded in."
      I verified if it was set up correctly and the mesh already had 3 all slots filled in. But unfortunately it still disappears. I understood advice was meant for the High - Med - Low slots in the 'Meshes' tab.

      I did a few more tests using a very simple test case with 2 lods:
      - I tried exporting just the custom trunk mesh as a zone generator. In Unreal no Lod's are imported except the first level, lod0
      - When I add branches to the zone trunk, the zone trunk lod1 disappears within Unreal while the branches remain
      Seems like a bug ?

      I got the fronds working now by playing around with the settings for the branches. I'm only using the Zone generators as size reference. Orientation is okay, but scale has to be set manual. And since my trunk and roots of the tree use to materials I've to use 2 Frond generators that I've to manually scale to make sure they fit together perfectly. Just eyeballing it. It's not ideal workflow and feels more like a workaround.
      - Is there any way to use the 'actual size' for the meshes in the frond generator ? The option exists within the zone generator
      - Is it possible to have a single custom mesh asset with 2 or more different materials ?

      Kind regards,
      Roel
      Attached Files

      Comment

      Working...
      X