Announcement

Collapse
No announcement yet.

Dynamic LODs stopped working v8.4.2 (unity Subscription Edition)

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Dynamic LODs stopped working v8.4.2 (unity Subscription Edition)

    Hi


    I was happily optimizing a mesh... and then the Dynamic LODs curves stopped working for me in the sense that I see no mesh or polygon count updating. I may be missing something but everything was working fine and now it doesn't, like something just switched off.

    <solution below at EDIT>

    In the dynamic LOD on the root tree node, I can still see a response when I...
    • Enable/disable
    • Change the number of LODs
    • Use the LOD slider in the view port to see the different LODs
    but nothing happens anymore when I...
    • Edit the curves
    • Edit leaf settings /including changing seed
    On any child node, in dynamic LOD tab, nothing happens anymore when I...
    • Edit any setting - I can use the sliders to change values and play with the curves, but nothing on the model is changing.
    So I created a brand new scene and added a trunk, same issues - the LODing did not work/update on nether the triangle counts nor with the wire-frame selection style turned on. So something seems broken.

    I tried restarting ST - issue still exists.
    I tried restarting PC and then ST - issue still exists.

    I read that there has been some similar issues in the past, but were fixed. Maybe this is the ghost of that coming back to haunt?

    I'm going to next reinstall ST, I'll edit this later to see if that fixes it. Hopefully it will.




    EDIT: OK, worked out what I did wrong .I'll leave this here in case some one else is has the same thing. No need to reinstall or anything. Just check this first...


    It was connected to something seemingly unrelated, so I must have inadvertently changed something. My bad. Doh!

    It was to do with frond materials not using their correct meshes. I had set this all up correctly before, so I must have changed it without realizing. Not sure how though, but nice to know it all works again


    Click image for larger version  Name:	FrondMeshes.jpg Views:	1 Size:	135.6 KB ID:	9586


    Edit#2 - After some further work I had the above correct but encountered it again. It looks like some conflict with the node LOD tab/ Dynamic LOD curves and settings can contribute. Cancelling out and trying again can help


    Last edited by jezelf; 02-23-2021, 05:32 PM.

  • #2
    Thank for letting us know, jezelf! Glad you resolved the issue! We'll be here if you encounter any other problems!

    Comment


    • #3
      Thanks KatLeeHong


      I'm actually not yet 100% sure I've solved it or if I happened upon some fluke hacks that reminded ST what to do.

      It could be that I'm creating some feedback conflicts with the root dynamic LODing and the individual node LODing and segment settings, but I would expect the root tree dynamic LOD would override it's children nodes, not the other way around, right?

      However it's still a mystery why a clean blank scene with a trunk and adding branches will still not work for me with a dynamic LOD, - I've just tried doing it again and it's not working for that. So it's possible there could be something deeper happening. I'm not actually working on that though, it was my 'neutral' test tree - but it's a bit concerning it's not working on that, so it might still be an issue other than me being dumb...but more likely the latter.

      I'll see how I go. I may come back for that help!

      thanks!

      Comment

      Working...
      X