Announcement

Collapse
No announcement yet.

Ue4 material preview not visible if speedtree wind = true

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Ue4 material preview not visible if speedtree wind = true

    I think this may be a bug. If I am using SpeedTree Wind node in material, it won't appear in material preview, nor the thumbnails. Makes things take longer like editing materials and even just finding materials I want to use at a glance. I've had this for awhile now, currently using UE4 engine version 4.26. I get around this by having two material instances per actual instance needed. Bug or something wrong on my end?

    Click image for larger version

Name:	2021-02-28 17_57_21-Prototyping - Unreal Editor.png
Views:	94
Size:	83.2 KB
ID:	9606

  • #2
    Hello,

    Unfortunately, this is just a consequence of using the WorldPositionOffset input on the material. Hook anything to that, and the preview sphere will move around. For instance, stick a Constant3(0, 0, 1000) on it, and the preview sphere will go away too (because it moves high enough to not be seen by the preview camera). It's not something specific to SpeedTree, though the SpeedTree node is the thing moving the sphere around because of wind.

    I'm not sure if I would classify it as a bug, but perhaps preview renders could ignore WorldPositionOffset. That would be a question for Epic.

    Wish I had an easy answer for you!

    Comment


    • #3
      I was unaware of that, thank you for informing me. It caused me to think of a solution albeit a hacky one, in case anyone finds this thread. It just disables WPO input if the object is at 0,x,x. Since object in preview is at 0,0,0 it'll be disabled, and enabled once in world

      I can now get rid of my duplicate materials.. Thanks!

      Click image for larger version

Name:	2021-03-06 16_46_12-Window.png
Views:	19
Size:	45.1 KB
ID:	9616

      Comment

      Working...
      X