Announcement

Collapse
No announcement yet.

Export hierarchy 

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Export hierarchy 

    Hello All.

    I am very new to SpeedTree.
    I want to export both mesh and spine data separately for use in Houdini.
    When I import the data in Houdini, there are branches that are not on the SpeedTree screen.

    I have found that if I set the Hierarchy in the Export settings to 4 or less, they do not appear, but then the number of branches is also reduced.
    What could be the cause?

    I am using SpeedTreeCinemamodeler 9.1.0 / Houdini19.0.455


  • #2
    Hey ysan, we've got a theory as to what might be happening but we'll need the tree file to be sure. Could you "save as with assets" into a new folder, zip it, and send it to us at [email protected] with a link to this thread? (It helps us follow-up after answering your email in support!)

    Comment


    • #3
      Hello KatLeeHong KatLeeHong
      ​​​​​​​
      I have sent you the file.
      Have you had a chance to check it?

      Best regards.

      Comment


      • #4
        Hey ysan, we've received your file but haven't had a chance to investigate yet. We'll get back to you as soon as we have an opportunity to look at your file.

        Thanks for following up!
        Last edited by KatLeeHong; 04-27-2022, 04:30 PM.

        Comment


        • #5
          Hello,

          Thank you for the file. It allowed us to find the issue.

          That branch actually is in your tree, just in a different place. What is happening is you split the tree up enough that a name clash happened on an object in the hierarchy. That made that branch show up in the wrong place in the hierarchy because Alembic requires unique paths (this bug didn't show in FBX, for example). We were trying to be smart about renaming things, but it wasn't enough in this case.

          I have fixed it for the next version. But in the meantime, rename your nodes to be more unique, specifically the Branch, Branch 1, and Branch 2 generators. Then you should not have any more trouble with Alembic.

          Comment


          • #6
            Greg Croft Thanks, I solved it by renaming the node!Click image for larger version

Name:	fix.jpg
Views:	24
Size:	121.7 KB
ID:	11266

            Comment

            Working...
            X