Announcement

Collapse
No announcement yet.

Low Resolution Leaves

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Low Resolution Leaves

    Hello everyone,
    I'm fairly new to SpeedTree and am having some issues with getting the same resolution textures into Unreal Engine 5.1.

    The issue is simple: The leaves/needles shown in the SpeedTree are high resolution. I export the tree asset using the UE4 preset, import that tree into unreal engine 5.1, and then find that the leaves/needles are exceptionally low resolution in comparison to what was in SpeedTree. I increased the export variables in hopes it would help with the resolution, but it did not help. (Images below)
    Would anybody have a solution to this? I'm at a loss, been searching the web and the forums a bit but haven't found anything. I feel as though I'm overlooking something or making a rookie mistake. Thank you in advance for any help.

    Here is a screenshot of a tree I'm trying to export, along with its export settings (I've been using "Export to Game"). This tree is generated using Juniper Rocky Mountain Forest Hero, purchased from the store.
    Click image for larger version

Name:	Screenshot 2023-01-19 164709.png
Views:	41
Size:	1.45 MB
ID:	12309

    And here is what I get in Unreal Engine:
    Click image for larger version

Name:	HighresScreenshot00002.png
Views:	22
Size:	5.60 MB
ID:	12310

  • #2
    I'd click the "Show Atlas" and see what kind of image you're getting there. I've on occasion found that my settings can result in the atlas space being used in very illogical manners, which results to an output that actually has very few pixels for the end result.

    Beyond that, I'd also check the opacity settings in your UE material to see if they're using the opacity mask correctly. Looking at the image it does kind of look like UE isn't cutting out the needles at all.

    Comment


    • #3
      Originally posted by FrostBear View Post
      I'd click the "Show Atlas" and see what kind of image you're getting there. I've on occasion found that my settings can result in the atlas space being used in very illogical manners, which results to an output that actually has very few pixels for the end result.

      Beyond that, I'd also check the opacity settings in your UE material to see if they're using the opacity mask correctly. Looking at the image it does kind of look like UE isn't cutting out the needles at all.
      Hey FrostBear, thank you very much for your response. I was thinking something along the same lines, too. I fiddled with the Opacity Mask Threshold in the Leaves Material Instance, but it was to no avail. It essentially just made the 'blobby' leaves smaller or larger. I suppose that was to be expected.

      I actually stumbled on the solution just now, and I feel a little silly for having overlooked it... The texture maps for the Leaves were imported as Virtual Texture Maps, rather than regular textures. I'm unsure why the textures would be imported this way outside of Virtual Texture Support simply being enabled in the Unreal Engine project settings. Maybe it's just the Unreal Engine project setting, the fact Virtual Texture Support is enabled. I know now to double check my textures/materials upon importing.

      If anybody has a similar issue like this when using Unreal Engine 5.1, do this:
      Open your Material Instance for the textures in question (in this case, it was just my branches/leaves) and look for any errors displayed as red text in the material viewport. It should be shown on the upper-left corner of the viewport. It specifically states that the texture maps must not be virtual texture maps in order to work with the SpeedTree Master Material. I had overlooked this at first.
      Then, I highlighted the textures in my content browser, right clicked them, and left clicked "Convert to regular texture" in the context menu. I had some issues with Unreal Engine freezing at this point as it would attempt rebuilding Texture Streaming and simply hang. I recommend immediately saving changes after converting the textures, and reloading your project. This resolved my issue.

      I hope this helps anybody who happens to make the same mistake.

      Comment

      Working...
      X