Announcement

Collapse
No announcement yet.

Tree fronds blacked out in ue4

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Tree fronds blacked out in ue4

    Hey, any ideea why my tree looks like this in UE4 ?

    This is how it looks in speedtree modeler :

    Click image for larger version

Name:	6b08dc5928.jpg
Views:	1
Size:	87.8 KB
ID:	3250

    And this is how it looks in UE4:

    Click image for larger version

Name:	287a1f8504.jpg
Views:	1
Size:	80.0 KB
ID:	3251
    Click image for larger version

Name:	7002731bbb.jpg
Views:	1
Size:	78.3 KB
ID:	3252

    What am I doing wrong?

  • #2
    Really no one knows?

    Comment


    • #3
      Hello,

      If your leaves don't have a normal map, you'll need to add a few nodes to the material to fix two-sided lighting. By default, UE4 flips the normal on the backside of two-sided materials. This works with solid meshes, but it isn't the correct way to light a SpeedTree (or any other foliage). This image shows what you should do to fix the normals on the backsides of two-sided materials. It already does this if there is a normal map on the imported geometry.

      Click image for larger version

Name:	normal.jpg
Views:	3
Size:	47.7 KB
ID:	2971

      Hope this helps

      Comment


      • #4
        Worked like a charm. Thank you!

        Any chance you can point out a tutorial or how to obtain branches for this kind of tree?

        I am thinking to model that using fronds with a force downwards. ( If you know a better way please do let me know , the one before was my first ever, and I found the branch on the web)

        Click image for larger version

Name:	1a7cb4c919.jpg
Views:	1
Size:	41.1 KB
ID:	2972

        Comment


        • #5
          Hi,

          Actually, the technique you mention is exactly the approach you need to take to achieve this look. MY one suggestion is to be aware of the segment count of the frond you use. The Default of the fronds has a pretty high number for game trees, so automatically, you'll have to go to the 'Fronds' segments group and decrease those numbers.

          Here is a tutorial demonstrating the use of forces in modeling: http://www.youtube.com/watch?v=sm3qh...AA8FD10C800614

          Hope this helps!

          Comment


          • #6
            Hi Sonia,

            Thanks for dropping in to help!

            This is what I managed to do so far and is not even close to the quality I need it to be :

            http://puu.sh/c3gQQ/7b13d66f9d.jpg
            http://puu.sh/c3hgk/67c8ae6a8b.jpg
            http://puu.sh/c3hiu/19e8b40d3d.jpg
            http://puu.sh/c3hji/2d22d8ea18.jpg

            Hoping you can give some feedback/ teach me how to make this better.

            1.There is the error with mesh not having unrwapped UVs.

            2.This is the diffuse I'm using for the fronds : http://puu.sh/c3ho6/62eb907c88.png . I coudln't find a higher res one, is it good enough?

            3. In ue4 it looks way worse then this ( I am guessing because of the unrwapped UVs)

            Comment


            • #7
              Any feedback on how to improve this?

              http://puu.sh/c60xi/32da558bf1.jpg

              Comment


              • #8
                Wondering why I don't get my posts approved or why they need to get approved in the first place.

                Comment


                • #9
                  The approving of posts is to avoid spam, it is a normal process for everyone who posts onto the forum.

                  As for the the tree. The texture your using has too many overlapping branches and leaves. I would suggest deleting some in order to get some nice spacing and gaps. Also, the texture gets cut off at the top. When I look at the tree image you posted, I can see the abrupt cut. I would clean that up as well. As for the branches, I would show more of them and add less frond meshes on the branches. Normally, with weeping willows, you can see the branch structure through the leaves. Sometime less leaf clutter is better. You can also do this by enabling 'Leaf Collision', under 'Tree Properties'.

                  I am sending a private message of a download link. Studying this should help.

                  However, this tree has not been modified for UE4, so on certain meshes you will get the over-lapping UV error. As you mentioned earlier, you were getting that error. Reasoning being that either the UV vertices are either outside the 0-1 range, or some of the points are sharing the same space on the texture. Each vertex needs it's own individual place and when they share the same spot on the texture then it doesn't translate well into UE4.

                  I hope this helps!

                  Comment


                  • #10
                    Thank you so much!

                    That was more than I could ask, it did help a lot!

                    Comment


                    • #11
                      Originally posted by SoniaPiasecki View Post
                      The approving of posts is to avoid spam, it is a normal process for everyone who posts onto the forum.

                      As for the the tree. The texture your using has too many overlapping branches and leaves. I would suggest deleting some in order to get some nice spacing and gaps. Also, the texture gets cut off at the top. When I look at the tree image you posted, I can see the abrupt cut. I would clean that up as well. As for the branches, I would show more of them and add less frond meshes on the branches. Normally, with weeping willows, you can see the branch structure through the leaves. Sometime less leaf clutter is better. You can also do this by enabling 'Leaf Collision', under 'Tree Properties'.

                      I am sending a private message of a download link. Studying this should help.

                      However, this tree has not been modified for UE4, so on certain meshes you will get the over-lapping UV error. As you mentioned earlier, you were getting that error. Reasoning being that either the UV vertices are either outside the 0-1 range, or some of the points are sharing the same space on the texture. Each vertex needs it's own individual place and when they share the same spot on the texture then it doesn't translate well into UE4.

                      I hope this helps!
                      I'm having a similar problem with my tree. Everything seems fine, but inside unreal one my trees is completely black, and I get the UV error. I read through this topic and went over an amount of things. There seems to be no problem... but how do I check my UV layout within speedtree? I fixed lightmap density etc. but don't see any options to simply look at my uv-layout... and thus if they are overlapping or not.
                      Any suggestions? Or perhaps if there is such a thing, how do I fix/change this?

                      Comment


                      • #12
                        Hello,

                        There is a page in the docs explaining how to adjust lightmap UVs:
                        http://docs.speedtree.com/doku.php?i...ap_uvs_for_ue4

                        Do you mean you are getting an error about the UVs inside UE4? There should never be anything that overlaps... unless one of your mesh assets already has overlapping UVs. If that is the case, the Modeler will warn you about it, and you'll need to fix the mesh.

                        Comment


                        • #13
                          Originally posted by Greg Croft View Post
                          Hello,

                          There is a page in the docs explaining how to adjust lightmap UVs:
                          http://docs.speedtree.com/doku.php?i...ap_uvs_for_ue4

                          Do you mean you are getting an error about the UVs inside UE4? There should never be anything that overlaps... unless one of your mesh assets already has overlapping UVs. If that is the case, the Modeler will warn you about it, and you'll need to fix the mesh.
                          Thanks for replying Greg,

                          I edited the lightmaps and now my models seem to be fine. Thank you.

                          I have another question to ask, however, regarding how UE4 captures lighting on my leaves. Do you have any idea on how to fix it so that my trees don't look like they have a white border on the leaves?

                          It currently looks like this inside Unreal, but looks different in SpeedTree. http://gyazo.com/c03db16ca21cc31459e578e665141691

                          Comment


                          • #14
                            You need to make sure the color in your texture extends beyond the alpha mask. When the texture is mipmapped, it's pulling in the surrounding white color.

                            If you make your textures using the SpeedTree Modeler, we do this for you:
                            http://docs.speedtree.com/doku.php?id=export_material

                            If you're just making them in photoshop or some other graphics program, you'll need to dilate or "streak" the color channels. This web page includes a photoshop action that simulates it:
                            http://docs.unity3d.com/Manual/HOWTO-alphamaps.html

                            Comment

                            Working...
                            X