Announcement

Collapse
No announcement yet.

Unable to reimport trees into UE4

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Unable to reimport trees into UE4

    I have purchased the UE4 speedtree subscription and I'm having a couple issues with it:

    1) I am able to import my tree just fine, but when I modify it in speedtree and then try to reimport into Unreal, the model does not get updated, nor do any of the textures or materials. The only thing that changes is the scale of the model based on what scale I type into the import dialogue. I've tried lots of workarounds, but to no avail - what am I missing?

    2) I am noticing that sometimes the generation rollout does not contain all the controls it's supposed to. Often I will select a node and only the "shared" rollout available, and even that only contains size scalar and sink options. I can't for the life of me figure out what causes this to happen for some nodes and not others.

    Thanks in advance for any help you all can give me!

  • #2
    Hello,

    1) Be sure you save the tree in the Modeler and wait for it to finish compiling (if it's a big tree, a dialog will pop up to show progress) before reimporting. That's the only thing I can think of that could cause reimport to not update to match.

    Textures, however, will not reimport when you reimport the tree mesh itself. The importer will create the textures if necessary, but it will not force them to reload. But you can select the textures and reimport those, too. Perhaps we can add a feature to reimport the textures, too.



    2) I'm not sure I have ever seen that happen. If you get it in that state, could you take a screenshot and post it? Are you sure you're not just looking at the Tree node, which only has a shared and geometry section under generation?

    Comment


    • #3
      Thanks, Greg.
      1) Yeah, I tried reimporting the textures individually. It gives me a message "suchandsuchtexture successfully reimported from blahblah.stm" but the texture does not change.

      2) This is happening to me consistently, I can only assume I am simply doing something I don't don't better than not to do.

      Click image for larger version

Name:	Generation_reduced.jpg
Views:	1
Size:	91.9 KB
ID:	2973

      Comment


      • #4
        That's a hand-drawn branch, so it doesn't have generation properties (nothing is generated, you're drawing them).

        Comment

        Working...
        X