Announcement

Collapse
No announcement yet.

Grass black and Models fading out in UE4

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Grass black and Models fading out in UE4

    I made a custom grass in SpeedTree and when I import it into unreal, it appears black with baked lighting and it fades from view when the character walks a short distance away. I tried looking for the culling settings that are there for leaves. On the blades node there is nothing of the like! What do I do??

  • #2
    Hello,

    Just to clarify, there is no "blades" node. That is a spine generator named renamed to "blades". That should help you find documentation if necessary

    I imagine that you need to adjust how that model LODs. The overall level of detail properties are on the Tree generator (number of LODs, etc). For grass, you probably don't want LOD, to be honest, but you can set the number there. Then you adjust how each generator behaves during LOD with their properties. See this docs page for more information.

    For problems when baking lighting, you probably need to adjust the lightmap UVs. See this docs page on the process. If you're not using a normal map, be sure to see this post for how to fix the material for two-sided lighting.

    Comment


    • #3
      Thanks for the info,
      Now I've semi fixed my issue! In UE4 I disabled mip map dithering on my texture and that stops my grass from fading away. Also, with some light changes to my material I got some of my grass blades to turn green. Now only some of them are black. Will look into adjusting the Lightmap UV's

      Comment


      • #4
        Adjusted lightmap uv's still getting black grass blades =( Any other suggestions?

        Comment


        • #5
          Did you look at the aforementioned post about two sided lighting?

          You may also need to just adjust your normals. For grass, you pretty much want your normals to be pointing up.

          Comment


          • #6
            Yeah I added the nodes in my material for two sided normals. It was a notable increase color but still has several pieces that are black on both sides of the grass blade.

            Comment


            • #7
              So I just went and gave you more money and purchased some of your premade grass. I get a similar effect, except the wind doesn't work with your premade grass. I added that tidbit about not having two sided normals but I still have black blades of grass. What gives?

              Comment


              • #8
                Depending on the grass model, one of them comes into UE4 with palm wind enabled, when it should be fast wind. We have this issue logged already to fix.

                Go to the materials on that model, and switch them to use fast or fastest wind, and it should move correctly.

                I am unsure why you're having trouble with lighting, however. Which grass model did you purchase?

                Comment


                • #9
                  One of the lighting issues fell with the two sided normal, one of them had to do with unreal not liking streaming textures for Foliage painting. I turned off streaming in both my Albedo and Specular maps and then rebuilt my lighting. Worked like a Charm, also I found those wind settings you were referencing last night as well. Got both of those issues fixed now. Now I only have to figure out why one of my friggin landscapes keeps getting weird shadows >.< Ah well problems resolved! Thanks for your assistance sir!


                  Originally posted by Greg Croft View Post
                  Depending on the grass model, one of them comes into UE4 with palm wind enabled, when it should be fast wind. We have this issue logged already to fix.

                  Go to the materials on that model, and switch them to use fast or fastest wind, and it should move correctly.

                  I am unsure why you're having trouble with lighting, however. Which grass model did you purchase?

                  Comment

                  Working...
                  X