Announcement

Collapse
No announcement yet.

Locking unwrapped UV's for repeat exports

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Locking unwrapped UV's for repeat exports

    Hi,

    I am currently involved in a production of an animated movie for which we are using SpeedTree.
    Our workflow is such that we need to apply different tileable textures to out subdiv trees over the course of the production.

    Today we discovered that if we didn't get our tileable texture right the first time and we open our tree re-apply it and export unwrapped again to get applied texture we need Speedtree spits out the models and textures with a completely different set of UVs.

    Is there a way to not have the uv's change when we do this?

    It is a pain as we sometimes need to do quite a bit of cleanup after exporting from SpeedTree and not being able to simply render out a new tiled texture map every time we want to tweak textures makes us have to redo all these tweaks each time.

    Hopefully there is a setting somewhere that we've missed.

    Any help would be appreciated.

    Kane Croudace

    CG Supervisor
    Triggerfish Animation

  • #2
    Hello,

    Are your multiple branch textures different sizes? I could see that affecting the final result, because the texture size is one of the things taken into account during unwrapping. If you need the texture size to have no impact, then you'll want to put the "area to favor" slider all the way to "surface".

    Texture size can especially affect the final output if one texture changed size but other included textures did not (because everything is being packed together by relative size). In addition to the above, you may want to try exporting the branches separately from the rest of the tree. Then you can maintain the texture area option for the rest of the tree, but remove that from the branch layout.

    And finally, texture packing is a problem that is very hard for a computer to solve, so we take some liberties here and there to make it faster. You could try changing the algorithm from "fast" to "exact" to see if that packing, while slower, yields more stable results.

    Hope this helps

    Comment


    • #3
      Hi Greg,

      Thanks for your help, that does indeed work.
      Many gratitudes.

      Kane

      Comment

      Working...
      X