Announcement

Collapse
No announcement yet.

Overlapping lightmap UV's in UE4

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Overlapping lightmap UV's in UE4

    I've been getting the overlapping lightmap UV's error when doing lighting builds, but not on all trees. I've double-triple-quadruple checked everything and it's all set up right but the error doesn't go away for one of my trees. I'm tempted to think that it's an error in UE4, since some of my other static meshes get the error even when the UV's seem to be correct, but I can kill the errors anyway by letting Unreal auto UV these. That doesn't work for the speedtrees, though, so I thought I'd ask and see if anyone else is noticing these errors or knows something about what's going on with Unreal, or has an idea for something else I can try.

  • #2
    First, make sure any leaf meshes you are using are already unwrapped. The Modeler will warn you in the mesh asset tab if they are not (or in the output window when you load).

    Then check the lightmaps in the Modeler. If you pack something with a lot of vertices into a single texel of the texture, then you may have trouble in UE4. See the documentation section on tuning lightmaps: http://docs.speedtree.com/doku.php?i...ap_uvs_for_ue4

    Finally, in UE4 make sure you disable the automatic lightmap UV generation. Open the static mesh and in every LOD, uncheck that option if it is enabled and click apply. When that is on, it generates new UVs and doesn't use the ones you made in the Modeler. The automatic ones will most likely be pretty bad in comparison to the ones you make in the Modeler. In the next release, that will be disabled by default for SpeedTrees.

    Hope this helps

    Comment


    • #3
      Sorry to necro but this issue is still present, every time I build lighting I get the lightmap uv overlap isdue even though I do not see any overlap on the lightmap channel. Leaves the trees in a state of a hodge podge of dark shadows all over the models.
      any other fixes to this or are in theworks?

      Comment


      • #4
        Hi,

        In the modeler, when you are looking at the mesh in the 'Meshes' tab, do you see a 'Overlapping UV's' error? If so, this would cause some issues with lighting in UE4. You have to make sure when the UVs are unwrapped, that they don't overlap. Also, you want to make sure the are contained inside the 0 to 1 UV space.

        When in Light Map mode in the modeler, you want to make sure everything in the asset is green, not red or blue.

        Let me know if this helps.

        Comment


        • #5
          Looking at it I think I have found the problem, one of my leaf meshes is essentially a leaf cluster, the leaves in the cluster were clones sharing the UV space to save on texture space.
          They do have a lightmap channel set up to where the uvs are all separate, but it seems speed tree does not recognize custom uv channels other than the one which contains the uv layout for textures?
          Addionally it appears you can only import OBJ files as FBX gives errors.

          Comment

          Working...
          X