Announcement

Collapse
No announcement yet.

Rough grass lightmape/shadow problems

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Rough grass lightmape/shadow problems

    hey guys,
    I have here a little problem with one of the grass models "rough grass" from the speedtree store....
    After building the light i get some really weird black shadows "leaves"...
    Attached is also an image which shows the grass as "movable mesh" and as static mesh with lightmap issues...

    i just posted this also in the UE4 forum but it seams that no one knows whats going on...







  • #2
    Hello,

    Be sure that you have a two-sided sign node in the material in the expression for the normal. The importer has a bug where if it doesn't have a normal map, it doesn't account. See below for how this should be done when you don't have a normal map. This bug has been fixed and will be available in a future version (I'm not sure if it is in 4.6). You have to do this because by default, UE4 flips the normals on the backsides of two-sided geometry, which isn't the correct thing to do when lighting what amounts to a cloud of particles (like leaves or other foliage).

    Click image for larger version

Name:	normal.jpg
Views:	3
Size:	47.7 KB
ID:	2989



    Also, make sure you disable the automatic lightmap UV generation. Open the static mesh and in every LOD, uncheck that option if it is enabled and click apply. When that is on, it generates new UVs and doesn't use the ones made/tuned in the SpeedTree Modeler. The automatic ones will most likely be pretty bad in comparison to the ones you make in the Modeler. With UE4.6 and later, that should already be disabled by default for SpeedTrees.

    Comment


    • #3
      hey,
      thanks for the help... A two sided node was alreday assigned, also automatic uv generation was disabled by default...
      hmmm any other ideas why this is happening? I mean this black shadows are not how this grass model should look right?

      Comment


      • #4
        Which model are you using (i.e. hero cluster, etc)?

        Also, are you placing the grass as foliage or individual actors? Static lighting on foliage is relatively new, so maybe there is something going wrong there.

        However, lighting grass realistically is pretty different from trees. Grass doesn't have a lot of "substance" to it, and there is a lot of transmission of light through the blades. So face normals don't do a great job when you get right down to it. You could use subscattering, but that may be expensive for dense grass. You may want to just try sticking a 0,0,1 into the normal and disable "tangent space normals" so the grass always uses a straight up normal to light. That will get rid of the totally dark blades of grass. The SpeedTree AO can add some interesting lighting back into that, like darkening the bottom of the blades slightly. The best result probably would be to align the normals of the grass with the surface on which they are placed instead of straight up. Then you could have grass up on the side of the hill that lights well.

        Comment


        • #5
          I'am using the rough grass hero... please don't get me wrong but the sense behind buying a "ready to use" grass models from the speedtree store was for me to have a ready to use grass model for ue4 however there is clearly a problem with the shader.... i'm not sure if the "rough grass" should be sold in his current stage with this issue....

          I have some experience in shader setup, but i don't understand what i have to change for 100%... the second point is it should be definitly performance friendly...

          Comment

          Working...
          X