Announcement

Collapse
No announcement yet.

No *.SRT file generated

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • No *.SRT file generated

    Hi,

    I have a subscription for the Speedtree edition for Unreal Engine 4 and it works fine so far.
    Unfortunately, when I save a model, there is only a spm-file generated. There is no srt-file, which I need to import tu Unreal.

    What am I doing wrong?
    By the way: I use the UE4-subscription edition.

    Regards
    Chricken

  • #2
    Hi chricken, you need to compile your tree to create the .srt, its a separate program, you'll find it in your speed tree directory.

    Comment


    • #3
      Thanks for you reply mikebart,

      I found that compiler, but can't make it load the spm-file to compile it. Am I doing anything wrong?
      As far as I understood, the compiler is part of the API, if I want to have speedtree integrated into my software-project.

      Furthermore, all the tutorials (i.e. https://docs.unrealengine.com/latest...ree/index.html) explain, that I simply have to save the model in der UE4-edition and I get all the files I need. I gues, the problem is deeper inside.

      Regards
      Chricken

      Comment


      • #4
        are you going to file>open or are you clicking the 'add trees...' button in the settings dialogue? sorry if thats not it im not sure why you cant open the .spm, but the 'add trees.. button would be the correct way to open them.

        Comment


        • #5
          The UE4-specific Modeler will compile whenever you save; you don't have to run the Compiler directly (unless you want to).

          If you're not getting any warnings/errors in the Modeler's console, then the most likely cause is you need to apply materials to your tree. Compiling will only compile parts of the tree with a valid material. If you have none, then there is nothing to compile, and no srt file will be made.

          Comment


          • #6
            That might be it. I haven't applied a material yet.
            I'll check that in a few hours, when I am back in the office.
            That Information could be useful in the Dokumentation, that i've mentioned above. Couldn't it?

            Comment


            • #7
              Okay, I just applied materials to it and there are srt-files now.
              I can import them to UE4, it seems to work fine, now.

              Thank you

              Comment

              Working...
              X