No announcement yet.

Lightmap issues in UE4

  • Filter
  • Time
  • Show
Clear All
new posts

  • Lightmap issues in UE4

    The tree I am using is the speedtree "broadleaf_mobile" sample tree.

    After I build lightmap with high quality:

    Click image for larger version

Name:	lightmap_speedtree.PNG
Views:	1
Size:	383.2 KB
ID:	3314

    As you can see it looks terrible. Here is my UV unwrap:

    Click image for larger version

Name:	unwrap_speedtree.PNG
Views:	1
Size:	429.0 KB
ID:	3315

    Any help is appreciated. Thanks
    Last edited by 1635321; 07-28-2015, 09:21 AM.

  • #2
    The UVs on the model look great, so you're fine there.

    But the baked lighting is indeed terrible. However, it is also terrible on the terrain. Do you just need a lightmass importance volume to control the quality?

    EDIT: Actually, I take it back. I think the lightmap on the tree looks good. What I took to be an error seems to just be a branch. Are you just complaining about the shadow on the terrain? If so, increase the resolution of the lightmap on the ground and include a lightmass importance volume to improve quality.


    • #3
      Couldn't fix

      It is the shadow on the ground I am complaining about, however, adding a lightmass importance volume didn't fix the issue. Also, changing the resolution didn't fix it either.

      I'm not sure if this is helpful but if I use dynamic lighting it looks great, it's just the baked lighting that is an issue.

      Also, what resolution would you recommend for the ground?
      Last edited by 1635321; 07-28-2015, 11:00 AM.


      • #4
        Ok, well the shadow on the ground doesn't really have anything to do with SpeedTree. The tree's lightmap UVs work on the tree. Everything else is determined by light/shadow settings in your scene or on the terrain itself.

        Be sure to look through the UE4 documentation for information on adjusting static shadows. The page below should be particularly helpful, specifically the section on lightmap resolution for static lights.