Announcement

Collapse
No announcement yet.

Welding Enabled False crates gap

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Welding Enabled False crates gap

    Hi,

    I struggle with welding issue between my hand-made branches.

    I make same trees in two specs, high and low poly for various platforms. I love how nice welds SpeedTree allows me to do for high spec trees, but for low spec, I wish to be make just intersections between small and big branches.
    When I choose welding as False, Speed Tree creates a gap. Is that normal? How to get rid of it? Sinking branch offsets it into side unfortunately.

    I would leave it as Enables, but then I have 3 useless loops, which I didn't figure out how to remove neither.

    Is the only way to fix it, by moving branch by XYZ coordinates in the "Common" section, by hand?
    I hope you will advise something better, thanks.
    Last edited by ArturPerzyna; 11-06-2018, 08:23 AM.

  • #2
    Hi,

    I am not sure why this would happen if you do not have 'Sink' or any node edits. Would you mind sending a zipped file to support@speedtree.com? Just do a save as into a new folder and zip that. Also, I just want to make sure which version of the modeler you are using, it's v8.1.5 correct?

    Thanks!

    Comment


    • #3
      Hi,

      Project attached and sent.

      Many thanks,
      Artur

      Comment


      • #4
        In the same project file, bug occurs, which causes loosing material, when undoing some type of last actions, completely not related with material assigning. Even after saving and loading project file.

        Comment


        • #5
          Hi,

          Updating to v8.2 should fix these issues for you.

          Thank you for the file!

          Comment


          • #6
            It is fixed! Many Thanks

            Comment


            • #7
              Although I see occasional holes in my trees geometry. Small crevices visible under certain angle, showing that branch does not match parent branch.
              My previous solution for that was "Sink" option. Doesn't help anymore. SInk works differently in the new 8.20 version Affects Branch anchor, leaving broken weld as it is.
              Attached Files

              Comment


              • #8
                Is there any way to prevent UV stretch on welds?

                Attached Files

                Comment


                • #9
                  The branch weld issue seems to be cause by it's placement on that bend. I would suggest moving up slightly so it isn't placed there, it should get rid of that. Or you could add more segments to the parent branch.

                  As for the texture stretching, that can occur when the lower or upper spread has been pushed too far. You can try to edit that branch generators Skin -> Welding -> Blend properties and see if that fixes the stretch. If this doesn't work, I would suggest lowering the lower spread amount some.

                  Hope this helps!

                  Comment


                  • #10
                    Adding extra segments is quite expensive, moving branch usually helps, but still would love to could sing, offset branch to stick it into trunk and this way avoid gaps between them.

                    Comment

                    Working...
                    X