No announcement yet.

Using Megascans in Speedtree

  • Filter
  • Time
  • Show
Clear All
new posts

  • Using Megascans in Speedtree

    Good evening all,

    I'm starting with speedtree due to a need in upcoming production of mine. We will be using photogrammetry or megascans library for the main tree trunk however I can't figure out how to generate branches of that mesh and I can't find any useful tutorials online to help me with it.
    I saw the cool showoff from speedtree guys about photogrammetry in speedtree, but it's only a showoff.

    Mieszko Lacinski

  • #2
    Hi Mieszko,

    We will soon have some tutorials released on that topic, however until then, here is a link to our documentation page explaining how to achieve this.

    This page describes how to grow a ST procedural branch from your imported photogrammetry mesh:
    With this approach, once you have your trunk mesh, right click in the 'Generation editor' -> 'Add Geometry to selected' -> 'Photogrammetry' -> 'Click Placed Branches'. A 'Target' and 'Branch' generator will appear. Then in the viewport window, you hold down the spacebar and click on the point you want the branch to be placed. You can add as many branches as you like. Something to keep in mind is that if you click somewhat off the edge of the imported mesh, the branch won't be able to weld. So you can fix this by going to the 'Node edit' mode and moving that branch into place, just click that branches target (round ball with a red dot) and hit the 'T' button. You may have to also adjust the start angle.

    This page describes how to attach another imported mesh onto your photogrammetry mesh:

    Let me know if this helps!


    • #3
      I'm getting only some errors about parent being too short. I was getting it on megascans obj but switched to the template one and still get that. I played around with target as closest point eventually settled for laser controlled beam. Also When I control the laser's trojectory I don't get this pretty icon that is in the documentation. I don't care but It's weird. I would be more confident if I would be getting the same result as in the documentation. Then I add in a simple generator ---> branch. Twick some parameters and I get the error saying that the parent is being too short. Please see the screenshots underneath.
      Attached Files


      • #4
        but with placing a leaf generatior instead of branch works, however it doesn't work with most of other generators


        • #5

          Did you use the 'Photogrammetry' -> 'Click Placed Branches' template? This has already been set up to work.

          Let me know if this helps!