Announcement

Collapse
No announcement yet.

main trunks missing animation on import

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • main trunks missing animation on import

    Hey there, I'm experimenting around with speedTree Studio and I'm having trouble importing it with animation properly into maya 2012. To begin, I loaded up the sample broadLeaf High Detail tree in speedTree and throw the default wind on it. Then I exported it with wind. Once in maya, I import it using the speedtree fbx plugin, and it it looks great. But when I play it back, there's only animation on the leaves and secondary trunks. The two main trunks aren't moving/swaying at all. In speedTree all the branches/trunks including the main ones were swaying subtly. Any idea why this would be happening? Thanks!

  • #2
    I'm not ruling out a bug, but it could be the wind strength you used in the export dialog was lower than it was in the Modeler.

    Also, gusting could be working in the Modeler, while you may have disabled it in the exporter or didn't record long enough to get a gust. If you turn off gusting in the Modeler, the main trunk barely moves.

    Try turning up the wind strength when you export and see if the trunk moves at all.

    Comment


    • #3
      Sorry for the delayed reply, I figured out the problem. I was just applying the default wind by pressing 8 and making no further adjustments. When I actually went into each of the nodes, specifically, the trunk node, I noticed that the wind attribute was unchecked, whereas all the others had it checked. I figured the wind got applied to all the nodes by default, because I can see the main trunks swaying in the modeller, but I guess this may not be the case. In any case it seems to be working fine now after bringing it into maya!

      Comment


      • #4
        Global wind should still apply to the trunk, even if it doesn't have a branch level assigned to it (which is what happens when you enable wind on it). But like I mentioned, on that particular tree the global motion doesn't ramp up until the wind strength is higher, so you may not have been seeing it. You can edit the wind parameters by clicking on the fan, btw.

        Comment

        Working...
        X