Announcement

Collapse
No announcement yet.

LOD0 Mesh error when imported into Unity

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • LOD0 Mesh error when imported into Unity

    Hi all,


    First time posting here as I usually try and find an answer myself on the interwebs. Unfortunately I can't find a solution for a problem I'm currently experiencing (that or I'm not describing the search terms well enough).

    I've created a tree model inside of SpeedTree. It has 3 LODs and looks how it should from within the program:

    Click image for larger version

Name:	SpeedTree_01.jpg
Views:	245
Size:	60.7 KB
ID:	6053

    I then export the model to Unity with the following export options:

    Click image for larger version

Name:	SpeedTree_02.jpg
Views:	166
Size:	34.1 KB
ID:	6054

    In Unity I drag and drop the tree from the project window into the level and I get this problem on LOD0:

    Click image for larger version

Name:	SpeedTree_03.jpg
Views:	162
Size:	57.1 KB
ID:	6055

    LODs 1 and 2 are fine and reflect what it looks like in the SpeedTree but I can't work out why the LOD0 is coming out so funky. It looks like the vertex ID has been corrupted at some point as the mesh stretches in odd ways.

    Click image for larger version

Name:	SpeedTree_04.jpg
Views:	178
Size:	14.4 KB
ID:	6056
    Click image for larger version

Name:	SpeedTree_05.jpg
Views:	184
Size:	18.1 KB
ID:	6057
    Click image for larger version

Name:	SpeedTree_06.jpg
Views:	182
Size:	18.0 KB
ID:	6058

    This is the first time it's happened but isn't the first time I have exported/imported a SpeedTree model (I did three a few days ago with no problems).


    Any help is appreciated!



  • #2
    Hi,

    Seems like the export failed somehow, have you tried re-exporting the model from modeler and re-importing it into Unity? This should fix it.

    Let me know if this helps!

    Comment


    • #3
      Hello,

      Yep, I've tried re-exporting it with the same filename, a different filename, randomised the settings and exported that. All paths lead to the same outcome. I moved onto a bush and now some grass since and these are exporting fine. I'm not doing anything out of the ordinary on the tree which is why the error is weird.

      Comment


      • #4
        Hi,

        Would you mind send me the tree? Just do a 'Save as with Assets' into a new folder, zip it and send it to [email protected]

        Thanks!

        Comment


        • #5
          I've just sent it over. Thanks for helping!

          Comment


          • #6
            Did you manage to fix this issue? Looks like the same problem I am having right now

            Comment


            • #7
              Yes!

              Sorry I should have posted the solution before. My highest tree LOD was over 50K polygons. Reducing this to be under 50K fixed the issue.

              Comment


              • #8
                Awesome thank you! Must have missed this in the documentation.

                Comment

                Working...
                X