Announcement

Collapse
No announcement yet.

Textures don't look right in Unity.

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Textures don't look right in Unity.

    I'm having major issues with my textures.... For the life of me I can't figure this out..

    Left side is Unity. The right side is SpeedTree 8.3.0 Modeler.

    Any help that can be provided would be greatly appreciated.
    Thank you,

    David.

    Click image for larger version

Name:	SpeedTree8_3_Unity3D.png
Views:	99
Size:	608.0 KB
ID:	6226

  • #2
    Hi,

    Would you mind sending me some screenshots (listed below)? It will help me figure out what is going on.

    1. A screenshot of your export settings from the ST modeler.
    2. A screenshot of your material in the ST modeler.
    3. A screenshot of your material in Unity.

    Thanks!

    Comment


    • #3
      This looks like the normal map fix isn't applied and the hue variation change is applied, i. e. where everything becomes orange-y.

      Comment


      • #4
        I think the issue here is that you're exporting Atlas - "everything", so I think (?) when you do this, ST exports your bark as a unique, non-tiling bark texture at super low resolution.

        Try non-wrapping:
        Click image for larger version  Name:	STexport.PNG Views:	0 Size:	35.9 KB ID:	6250

        Comment


        • #5
          Yeah it was the Atlasing.
          Sorry for not replying sooner.

          I just tried the "Non-wrapping" and it doesn't appear to be - well - atlased.
          Which brings us back to - higher draw calls

          Assuming atlasing is more for - mobile and/or objects that are small (such as clovers, etc) as the details are so small.

          Comment

          Working...
          X