Announcement

Collapse
No announcement yet.

Black leaves from 1 side

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Black leaves from 1 side

    HI
    How to turn off the light or AO
    Cause after exporting in Unity grass i got black 1 side
    I turned shadows in Unity but didnt help
    In SpeedTree i down know or cant turn it offClick image for larger version

Name:	grass111.PNG
Views:	47
Size:	229.8 KB
ID:	6302

  • #2
    Hi,

    This could be cause because of subsurface. In the modeler, does the material have a subsurface map or color and, for the 'Subsurface Amount', a value other than 0? I would suggest to test it by changing the 'Subsurface amount' to 1 and see if that fixes the issue.

    Hope this helps!

    Comment


    • #3
      Originally posted by SoniaPiasecki View Post
      Hi,

      This could be cause because of subsurface. In the modeler, does the material have a subsurface map or color and, for the 'Subsurface Amount', a value other than 0? I would suggest to test it by changing the 'Subsurface amount' to 1 and see if that fixes the issue.

      Hope this helps!
      Cant find it

      Comment


      • #4
        I saw another post you made and realized you are using the v7 modeler. With this version the subsurface was known as the Transmission and that was placed in the alpha of the specular map.

        Here is a v7 documentation page describing the Material set: docs.speedtree.com/doku.php?id=material_assets

        For the grass in this version, I would suggest making them by using the 'Mesh Fronds' generator and hiding the branch. With this, you would have more control of the shape without having to go into an outside program. You would then need to edit the Frond -> Normals to get better lighting. You can see how the normal are being altered by going to the tool bar above the viewport -> Click 'Show' and then 'Normals'.

        Here is a link to a documentation page about Mesh Fronds: http://docs.speedtree.com/doku.php?id=mesh_fronds

        Hope this helps!

        Comment


        • #5
          Originally posted by SoniaPiasecki View Post
          I saw another post you made and realized you are using the v7 modeler. With this version the subsurface was known as the Transmission and that was placed in the alpha of the specular map.

          Here is a v7 documentation page describing the Material set: docs.speedtree.com/doku.php?id=material_assets

          For the grass in this version, I would suggest making them by using the 'Mesh Fronds' generator and hiding the branch. With this, you would have more control of the shape without having to go into an outside program. You would then need to edit the Frond -> Normals to get better lighting. You can see how the normal are being altered by going to the tool bar above the viewport -> Click 'Show' and then 'Normals'.

          Here is a link to a documentation page about Mesh Fronds: http://docs.speedtree.com/doku.php?id=mesh_fronds

          Hope this helps!
          Could you repeat but little easier please?))
          I should remake grass by using fronds instead of leaves?

          Comment

          Working...
          X