Announcement

Collapse
No announcement yet.

make lod use high > medium > low poly leave meshes instead of dynamic lod

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • make lod use high > medium > low poly leave meshes instead of dynamic lod

    I made different meshes for the leaves and fronds im using which go from ~55 verts (high) to ~25 verts (medium) to ~8 verts (low) how do i switch the dynamic lod for using those meshes instead? i dont like dynamic lod because the pop in with the leaves is too obvious, im working on a conifer model and more than half the tree including the trunk literally disappears on the first lod and in general all the trees look really bad because you can see the leaves pop in and out very obviously. none of the weighting settings on the leaves and fronds change anything about it, and changing the curve for "leaves" and "fronds" in the global properties works but it doesnt switch the leaf meshes from lod0=high to lod2=low

  • #2
    1. RadicalRadish is a fantastic user name.
    2. If you're using the SpeedTree mesh cutout creator you can set your polygons in the mesh in the "high" "medium" and "low" slots. On the leaf or frond generator in the property bar there is a section for LOD. The mesh curve there needs to be set to linear decay to drop in polygon count. The dynamic lod is a system in place to hide the pop. Adjusting the branch and leaf curves will help balance what is being taken away.
    3. To fix the trunk issue- place more weight in the trunk mesh generator to keep it. Usually a parent curve placing more weight on the outter branches will help you hold the shape better as you lod.
    4. Custom meshes loaded in from the mesh toolbar can be used instead but keep in mind that this method will take some heavier editing to control the pop.

    Comment


    • #3
      Originally posted by SarahScruggs View Post
      1. RadicalRadish is a fantastic user name.
      2. If you're using the SpeedTree mesh cutout creator you can set your polygons in the mesh in the "high" "medium" and "low" slots. On the leaf or frond generator in the property bar there is a section for LOD. The mesh curve there needs to be set to linear decay to drop in polygon count. The dynamic lod is a system in place to hide the pop. Adjusting the branch and leaf curves will help balance what is being taken away.
      3. To fix the trunk issue- place more weight in the trunk mesh generator to keep it. Usually a parent curve placing more weight on the outter branches will help you hold the shape better as you lod.
      4. Custom meshes loaded in from the mesh toolbar can be used instead but keep in mind that this method will take some heavier editing to control the pop.
      thanks a lot hahahahah appreciated
      "On the leaf or frond generator in the property bar there is a section for LOD. The mesh curve there needs to be set to linear decay to drop in polygon count."
      thats exactly what i needed!! thanks again i set it up that way and now the pop in is way less obvious.

      Comment


      • #4
        Originally posted by SarahScruggs View Post
        3. To fix the trunk issue- place more weight in the trunk mesh generator to keep it. Usually a parent curve placing more weight on the outter branches will help you hold the shape better as you lod.
        this never works for me for some reason. no matter how high i set it (1 - 100 -195120 you get the idea) the trunk will ALWAYS pop out at the first LOD the same way regardless of what i set the weight to.

        Comment


        • #5
          What version number of the modeler are you using? What do your main LOD property settings look like for the trunk LOD and the whole tree?

          Comment

          Working...
          X