Announcement

Collapse
No announcement yet.

Speedtree Not Generating Lightmap UVs

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Speedtree Not Generating Lightmap UVs

    This is a screenshot of a tree that comes with Speedtree for UE4, and when I attempt to view the lightmap UVs it is blank. I've made a few of my own trees as well and they look exactly the same (empty UVs). It is causing my trees to render black within the engine. How can I make it so that Speedtree generates lightmaps for my scene in Unreal? I've done tons of online research and cannot find another case where the lightmap UVs are missing. My apologies if this is an obvious fix. Any advice would be greatly appreciated!

  • #2
    Hi,

    Hmm, this is indeed strange. When you click on the 'Global Properties' button and scroll down to the 'Lightmap' -> 'Target Resolution' property, what is it set to? Also, when you select each of the generators and scroll down to 'Lightmap' section, try setting all the 'Weight' properties to 1. This should get them to appear, if they do, you will just have to tune them.

    Here is a link to our Lightmap documentation page: http://docs8.speedtree.com/modeler/d...?id=kclightmap

    This will explain in more detail what the properties do and how they should be tuned.

    Hope this helps!

    Comment


    • #3
      The target resolution is set to 256 with the display multiplier set to x1. I have tried every possible combination of these two settings with no change. All weight properties are set to 1 within each individual generator. Changing these numbers has no effect. I have attempted messing around with the curves as well (on default and in modes such as min, max, bell, etc.), and while some parts of the tree will go from blue to red (as shown in attached screenshot), UVs do not show up.

      If it's worth mentioning, I am on a Mac. The link to the Mac download on your website is broken, so I received a link through an email support sent me by request. I'm not sure if this has any relevance, but perhaps?

      Comment


      • #4
        This issue has since been fixed. I appreciate the help I received!

        Comment

        Working...
        X