Announcement

Collapse
No announcement yet.

Texture issues in Unreal

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Texture issues in Unreal

    I have noticed that when working with highly detailed textures for things like pine needles Unreal seems to turn them in to blurred clumps as the camera comes away. This is happening before the LOD's have even kicked in. It causes my pine needles to look like solid and not with the gaps between needles it gets filled in.

    Here is my tree in speedtree:



    As you can see the needles are well defined but as you see below they are clumpy with no gaps between needles:



    Does anybody have suggestions on how to overcome this issue?

    Here is the texture I generated:



    I used speedtree to make it:



    I found using a smaller density of needles does help with this however the tree then looks very bare. I am trying to model the Pinus Nigra which has long and dense needles.

  • #2
    Hi,


    This effect is happening because the mipmaps are getting slightly blurred. You can try to adjust settings on that texture to improve the quality in UE4 and you can also adjust the 'Alpha' settings to scale the alpha down a bit in order to have the spaces in the texture appear better.
    Here is a link to the UE4 docs, just look for Min and Max Alpha: https://docs.unrealengine.com/latest...ies/index.html

    Let me know if this fixes it for you.

    Comment


    • #3
      You have to edit the materials in UE4. Default materials from Speedtree are more of a head start than a finished material. There is also lighting and Anti-Aliasing in UE4 to account for to make vegetation look less muddy but you can disable that when you click the "show" button in you main view-port and uncheck anti-aliasing. Here are some examples of UE4 material setup for my branches.

      Here is my master material (WIP) to get pretty decent results.

      Click image for larger version

Name:	Capture1.jpg
Views:	1
Size:	92.5 KB
ID:	3048

      This is a RSS texture (Roughness, Specular and Subsurface in RGB channels) just in case you couldn't tell what was going on in the material.

      Click image for larger version

Name:	Capture3.jpg
Views:	1
Size:	90.5 KB
ID:	3049

      After that, just adjust your lighting and the results will be more clear. Test in different AA settings of your post process volume. Should be under Settings when you click your post process volume.

      Comment

      Working...
      X