Announcement

Collapse
No announcement yet.

Missing srt file

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Missing srt file

    Hey all

    I just started with speedtree and have opened one of the default files that comes with the product. Rough_Grass_Desktop

    clicking file save as I do not get a srt file

    checking the web I saw someone run a compiler and show how to get the srt file

    I have tried that also but still no srt file

    anyone have any ideas?

    I am running SpeedTree Modeller v7.1.2 Games Edition

    thanks Specter
    Last edited by specter; 01-22-2020, 01:59 AM.

  • #2
    Hello,

    Only the subscription versions of the Modeler compile a tree on save. You are using the full games version, so you need to use the Compiler.

    You can find documentation on using the Compiler here: http://docs.speedtree.com/doku.php?id=compiler

    The console in the Compiler will most likely alert you to any problems that occur during compilation. One common one is if you have not assigned any materials to the tree, no geometry will get compiled into the SRT file (and thus, no file is created).


    Hope this helps

    Comment


    • #3
      hello, thanks for the reply

      ok Launching the compiler and clicking the add ytree buttom then clicking general and then choosing a path then clicking compile generates the Atlas folder but doesn't generate the srt file

      in the log it says "> [Error]: Cannot locate the DirectX_9 shader compiler (most likely error is that the SDK for that platform is not installed). Try editing Compiler location manually in Compiler app: Edit->Preferences->Shader Compilers"

      Checking online some chap suggestied to install DXSDK_Jun10

      so I tried that then got an error

      Microsoft said I had to remove all other Visual C++ redists from my install to get round this error, which I have done this morning and the SDK installed

      but I am stil getting this error in the log file and no srt file is generated

      Thanks Specter

      Comment


      • #4
        Hello,

        We haven't updated v7 in a while, and Microsoft sometimes moves the path to fxc.

        First, make sure you have the latest Windows SDK (https://developer.microsoft.com/en-u...ds/sdk-archive) installed. Then go into the app preferences in the Compiler (in the Edit menu) and change the path to where fxc is located on your machine.

        That should allow the shaders to be compiled.

        Comment


        • #5
          excellent that worked a treat thanks very much

          Comment

          Working...
          X