Announcement

Collapse
No announcement yet.

Tree shading/normals incorrect

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Tree shading/normals incorrect

    I am brand new to speedtree, and am having trouble. I have tried making my first tree, but the shading is all wrong and I cant seem to fix it. I have gone through the lighting settings under my leaf mesh generator, but nothing seems to work. The tree looks much worse in UE4, and I suspect it has to do with the normals. I also have tried the example trees that come with speed tree, and they have the same issue, so im not sure if there is some setting i need to change or if speed tree just doesnt seem to play nice with UE4 at the moment. If anyone has any ideas I would greatly appreciate the help!
    Last edited by SappinSandviches; 12-30-2020, 05:21 PM.

  • #2
    Hello,
    In that particular tree, the cluster looks very flat- like maybe there is no normal or a flat normal loaded. The dark area is the backface normal, reflecting light in one solid sheet. In our clusters, we use variations in the normal under skin>lighting to turn the leaves different directions so the light doesn't hit it all at once in a "sheet". If you want to use the same lighting controls to puff out the light, that will help as well. Lighting that has been pulled too far to the backside will always show really black inside of unreal. You can make sure that's not happening by turning on the normal hints while you're editing (Show tab). Your specular, gloss, normal and ao all work together to cut down available light in engine. So you may consider your gloss values there as well.

    In v9 we've added an addtional feature to turn "flip backside normals" off that would allow you to set up the tree in the "lollypop" lighting style using the lighting controls. (coming soon).

    Feel free to post your pbr settings if you'd like some more specific help!

    Comment

    Working...
    X